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Title: BIM Architecture and Terrain Models with Revit 

1 – Aims 

Ability to develop a BIM Architectural Model, a Terrain Model, create schedules and sheets using 
Revit software; 

Ability to create 3D views and rendering using Revit software; 

Ability to transmit information using BIM. 

2 - Learning methodology 

The teacher will give an explanation about the use of the tool. 

Students will read this tutorial and see the videos, carry out the exercise and explore the 
architectural tools and environment. 

To assess the achievement of the practice, each student needs to create the terrain model, the 
architectural model, the sheets designs and the rendering. 

3 - Tutorial duration  

The practice described in this tutorial will be carried out in a computer classroom.  

It will last 8 teaching hours. 

4 – Necessary teaching resources  

Computer room with PCs with internet access. 

Required software: Revit  

Hardware required: Computer with the capacity to support the software. 

5– Contents & tutorial.  

5.1 Introduction 
5.2 Revit Interface 
5.3 Starting a project 
5.4 Definition of project levels 
5.5 Load a Family 
5.6 Import a CAD file  
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5.7 Create a Terrain Model 
5.8 Building Pads 
5.9 Create an Architectural Model 

5.9.1 Create walls 
5.9.2 Place Doors  
5.9.3 Place Windows 
5.9.4 Create Floors 
5.9.5 Create Stairs and Railings 
5.9.6 Create Ramp 
5.9.7 Create Roof 
5.9.8 Create Section Views 
5.9.9 Join Elements 
5.9.10 Components: Furniture 

5.10 Annotations 
5.10.1 Room Tags 
5.10.2 Text  
5.10.3 Dimensions 
5.10.4 Spot Elevation 
5.10.5 Tags 
5.10.6 Detail Lines 

5.11 Create Schedules 
5.12 Create Sheets and Print Setup 
5.13 Rendering 

6- Deliverables  

A report of 4 pages showing the execution of the exercise. 
 
7- What we have learned  

How to create and use BIM Modelling based on Revit  

How to create an architectural project model based on imported files in dwg format.  

How to create a terrain model, place construction elements (walls, doors, windows, floors, stairs, 
ramp, roof and furniture), insert annotations, create schedules, create sheets and rendering. 
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8 - Files to use in this tutorial 

Three files in dwg format: 
- Basement; 
- Ground Floor; 
- Elevations. 

 

--------------------------------------------------------x----------------------------------------------- 
 

5. Contents & tutorial 

5.1 – Introduction 

Autodesk Revit is a project software developed for architecture, design and engineering 
professionals, based on BIM technology, that makes it possible to develop several systems of a 
project, from its architectural and structural part to complementary systems such as hydraulics, 
electrical and mechanical systems. With Revit, it is possible to create a digital model of the building 
very accurately and efficiently. Each project includes a complete description of the construction and 
all the information needed to create 2D and 3D images, specifications and sheets. This information is 
stored in a single database, so that all components of the model are interconnected, and changes 
made in any view are automatically made to all other views in the project, without the need to 
change all the drawings individually. Revit also allows interoperability between several professionals, 
who can collaborate with the construction of the model (simultaneously or not). 

The educational version (for students and educators) can be downloaded for free through its 
website: 

https://www.autodesk.com/education/edu-software/  

 

If you don’t have access to the educational license, there is a trial version free for 30 days: 

 

https://www.autodesk.com/products/revit/free-trial 

 

5.2 – Revit Interface 

https://www.autodesk.com/education/edu-software/
https://www.autodesk.com/products/revit/free-trial
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Before starting a project in Revit, it is important to know its interface. There are several tools that 
help to improve the workflow during the project and understanding the organization of the interface 
is the first step. 

https://www.youtube.com/watch?v=sokRoynho3c  
 
  
 
 
 
In the image below, some groups of Revit tools are identified.  

 

 

 

 

https://www.youtube.com/watch?v=sokRoynho3c
https://www.youtube.com/watch?v=sokRoynho3c
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• Quick Access Toolbar - Contains a set of default tools. 
• Tabs - Contains the specific commands grouped by the name of the tab. 
• Panels - Subdivision of tools grouped within a tab. 
• Title Bar - Shows the title of the project that is currently open. 
• Type Selector - Allows object types to be selected from a Family. 
• Navigation Bar - Provides access to navigation tools and for the active 2D or 3D view. 
• Properties Palette - Allows the object's properties to be edited  before or after drawing it. 

Outside of a command and with no objects selected, it allows the view properties to be 
edited. 

• Project Browser - Shows a logical hierarchy for all views, schedules, sheets, groups, and 
other parts of the current project. 

• Drawing Area - The drawing area displays views (and sheets and schedules) of the current 
model. Each time you open a view in a model, the view is displayed in the drawing area. 

• View Control Bar - Provides quick access to functions that affect the current view (scale, 
level of detail, visual style) 

• Status Bar - Allows the status of the current command, or the name of the selected object to 
be known. 

• Selection Toggles - allows the elements to be selected to be filtered. 
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5.3 – Starting a project 

After opening the program, on the Revit homepage, click on New, Metric Architecture Template and 
select the Project option. In this case, we will use a predefined Revit template.  

 

After opening the Template, it is important to define the measurement units that will be used in the 
project. To do so, click on the Manage panel and select the Project Units option. 

 

Next, a window will be opened where the measurement units for each parameter are shown. We 
will change the Length that will be changed to Meters, with two decimal places and Slope parameter 
too, that will be changed to Percentage. For areas, volumes and angles, also two decimal places in 
the Rounding option should be defined. 
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5.4 – Definition of project levels 

The pre-defined template of Architecture provides only 2 Levels, and according to the need of each 
project, it may be necessary to create more. In this case, we will create one more level for Roof and 
change the names to make the project easier to see.  

To make it easier to change the names of the plan views, define the high dimensions of each floor 
and create a new floor, you can access a view in Elevations in the Project Browser. To access the 
view, just double-click on it (for example, in the East view). 
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With this view open, to change the height, just double-click on its value and type the value you want 
in the box, in this case, 2,6 m. The floor representation automatically adapts to the new height 
dimension. 

 

To rename the floors, proceed in the same way as when changing the height value, double-click on 
the name and rename the Level 1 and Level 2 floors to Basement and Ground Floor, respectively. 

To create a new floor for the Roof, on the Architecture tab, Datum panel, click on Level.(image). 

 

When you move the mouse cursor closer to the Ground Floor level, a temporary dimension will then 
appear in relation to the Ground Floor level, which serves as a preview of the level that will be 
inserted. As the mouse moves, the dimension changes. 
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Regarding the Ground floor, the new floor will have 3.40 m. After viewing the elevation of 3 .40 m, 
just click on a point of the drawing area and the new level will be inserted.  

 

It is possible to drag the extension of the line of the new level and leave it aligned with the others.  
For that, it is necessary to select the line and click on the circle on the left end of the line in “Drag the 
extents of the level in the model” and drag it until it is aligned with the lower lines. 

To rename the floor, the same procedure as the previous ones is carried out, in this case it will be 
renamed Roof, and if it is necessary to adjust the height, just double-click to edit the value. 

5.5 – Load Families 

The pre-defined Template provides only a minimal content of object families. To load more content, 
such as more door and window models, it can be done through two options: 

Revit 2022  

- Cloud Based (requires Revit 2021.1 or superior version, active Autodesk subscription and 
internet access). 

- Download Autodesk Content. 

In this case, we will choose to download content from the Autodesk website, through the link: 

https://knowledge.autodesk.com/support/revit/downloads/caas/downloads/content/autodesk-
revit-2022-content.html  

https://knowledge.autodesk.com/support/revit/downloads/caas/downloads/content/autodesk-revit-2022-content.html
https://knowledge.autodesk.com/support/revit/downloads/caas/downloads/content/autodesk-revit-2022-content.html
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The link provides family templates, project templates, and family libraries for Revit 2022 in all 
supported languages. Just choose the language and click on the title of the files to start the 
download. In this case, files for the Revit 2022 version were used.  

 
 

After completing the download, perform the following steps: 

- Run the .exe file from the saved location; 
- In the window that will open, specify the location of the wanted content (default 

destination folder “C:\Program Data\Autodesk\”) and click Extract. 
- The files will be extracted to the RVT 2022 and RLT 2022 folders where applicable. 

After installation, open Revit and click on the Insert tab, in the Load from Library panel and select the 
option Load Family.  

 

The Load Family window will open, and it is necessary to access the Revit installation folder (usually 
in Program Data > Autodesk > RVT 2022), inside the RVT 2022 folder, click on the Libraries folder and 
select the language that downloaded the Autodesk content (in this case, English). It displays all the 
folders with the families that have been installed. Select the Doors folder (Program Data > Autodesk 
> RVT 2022 > English > Doors). 
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When you click once on a file, a preview of the object appears. By double clicking it will be loaded. 
To load more than one family at the same time, you can select them by pressing the Ctrl key and 
clicking Open. 

 

After loading the “M_Door-Double-Sliding” door, for example, the Specify Types window will appear, 
with the dimensions options for this type of door. To select the wanted dimension, just  click once. 
To select more than one dimension, just press the Ctrl key, select the required dimensions and then 
click  on OK.  
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To confirm whether the family has been loaded, go to the Architecture tab, in this case select Door 
and check if the doors of the types and dimensions selected previously appear.  

 

For this project, import the following families of doors and windows (the size will be changed later):  

• Doors:  
M_Door-Double-Sliding  
M_Door-Garage-Flush_Panel  

• Windows:  
M_Window-Sliding-Double  
M_Window-Single-Hung  
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5.6 – Import a CAD file  

One of the most common ways to start a new project in Revit is to import a .dwg file. It is also 
possible to start a project in Revit without importing any files previously made in CAD, by inserting 
walls with the dimensions you want. 

To start the project of this tutorial it is necessary to do the exercise in the following video, using the 
files in .dwg format that were made available.  

https://www.youtube.com/watch?v=PF_mmxyo-1Y  
 
5.7 - Create a Terrain Model 

Revit offers more than one way to model the topographical surface  The simplest is to import a file in 
.dwg format that contains a survey with the contour lines in 3D.  

To import the file with the contour lines, it is important that it is at the same scale and coordinates in 
Revit. 

The contour lines will be imported into the Site view, which must be opened via the Project Browser. 

 In the Insert tab, select an Import CAD option.  

 

https://www.youtube.com/watch?v=PF_mmxyo-1Y
https://www.youtube.com/watch?v=PF_mmxyo-1Y
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Then a window appears to select the file to be imported, and it is possible to define all the 
parameters available for the import. Select Elevation.dwg file with just one click.  

 

In the import options, check that the Current view only option is not selected, so that the file is 
introduced in 3D (visible in all views). In the Layers field choose the option All (all layers of the file 
are imported). In Import units, choose the Meters option. 

In Positioning, select the Auto – Origin to Internal Origin option, making the DWG reference point 
the origin of the point with 0,0,0 coordinates of Revit. 

The Correct lines that are slightly off the axis option allows you to automatically correct lines that are 
slightly slanted (less than 0.1 degree). 

After defining all parameters, click on Open to load the file. The green contour line represents the 
terrain boundaries. 
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It is necessary to verify that the floor plans that have already been inserted in the project (Basement 
and Ground Floor) are aligned with the level curves file.(image) 

 

If they are not aligned, just click on the terrain and with the Move tool select one of the ends of 
the green outline and drag until you find the corresponding end of the plan. 

After importing the contour lines and aligning them with the other drawings, it is necessary to define 
the topographical surface. With the Site view open, access the Massing & Site tab, Model Site panel 
and click Toposurface. 
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In the Modify tab | Edit Surface, in the Tools panel, click on Create from Import>Select Import 
Instance and then select the drawing in the view. 

 

Select the layers that will be used to create the Toposurface. In this case, the Curves layer.  

 

After clicking on OK, a grid of points is generated. If a point is selected, in the Options Bar, the value 
of its elevation appears, which can be changed.  
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To finish creating the surface, on the Modify | Edit Surface tab, Surface panel, click Finish Surface . 

In order to better visualize the topographical surface, you can create a 3D view. Click the button 

 on the Quick Access Bar and a new view will be created in the Project Browser called {3D}. To 
improve the view even more, in the View Bar, change the view to Shaded. 

 

The result of the topographic surface in 3D will be as follows:  

 

It is possible to cut the topographic surface by the terrain boundary. Thus, there is no alteration to 
the adjacent terrain. 

To cut the terrain, open the Site view. With the view active, you cannot see the entire imported 
drawing (outline of terrain boundaries). This is because the topographic surface is on top of it. In the 
preview bar, change to Wireframe. 

 

With the perceptible drawing, you can define the cutout line. This will be defined by the green lines 
representing the terrain boundaries. To crop the topographic surface, access the Massing & Site tab, 
Modify Site panel, click on Split Surface and select the surface. 
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Select the Modify tab | Split Surface and with the drawing tools, define the corresponding 
perimeter, drawing lines above the green lines that represent the terrain boundaries. After its 

definition, click Finish Edit Mode  to exit edit mode. 

In a 3D view, and with the surface selected, the result will be as follows:  

 

There is also the Property Line tool, which serves to define the property boundary. This can only be 
used in plan views. Therefore, make the Site view current and confirm that it is in Wireframe mode. 

 In the Massing & Site tab, Modify Site panel, click Property Line. 

 

In the window that will open, select the Create by sketching option.  
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Again, select the Modify tab | Split Surface, and with the drawing tools, define the corresponding 
perimeter, drawing lines above the green lines that represent the terrain boundaries. After its 

definition, click on Finish Edit Mode to exit edit mode. 

To improve the visualization, it is possible to hide the topography outside the terrain limits, as well 
as the imported file of the contour lines. To do this, just select the element you want to hide and 
with the right mouse button, click Hide in View > Elements.  

 

The element will only be hidden in the open view, to hide it in other views, repeat the same process. 
It can be done for any element. 

After hiding the topography outside the terrain boundaries, and the contour file in the 3D view, we 
obtain the following result:  

 

If necessary, you can unhide hidden elements in view. To do this in the View Bar, click on the icon 

(Reveal hidden elements) and then all the hidden elements will be displayed in red.  
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Right-click on the element and then Unhide in View > Elements or Category. In the View Control Bar, 

click on to exit Reveal Hidden Elements mode and the elements will be visible in the view again. 

5.8. Building Pads 

It is possible to add a building pad to a toposurface and then modify the pad's structure and depth. 

The pad for the Basement floor will be inserted first. Open the Basement view and change the view 
to Wireframe (this allows you to see the imported .dwg).  In the Massing & Site tab, Model Site 
panel, click BuildingPad.  

 

With the Line tool, trace the perimeter of the entire basement layout (except the ramp that will be 
added separately). The lines must form a closed perimeter without crossing each other.  
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Before finishing editing the object, you need to define some properties. In the Properties Palette, in 
the Level parameter select Basement; this means that the pad will be associated with the level of 
that floor. In the Height Offset from Level parameter, introduce the value –0.10 m (this determines 
that the slab will be introduced 0.10 m below the Basement floor level) space to later place the 
finishing slab (Floor).  

 

Click on Edit Type to open the Type Properties window. In the Structure parameter click on Edit to 
edit the Structure layer thickness to 0,35 m. No new layers will be added for this element.  

 

After defining the thickness, click on OK until you return to the Drawing Area. Having defined all the 

necessary parameters, click on Finish Edit Mode . 

In the 3D view, the result of creating the Basement floor pad looks like the image below: 
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Now to create the pad for the Ground Floor level, you must open the view “Ground Floor.dwg”. In 
the same way as for the lower floor, access the Massing & Site tab, Model Site panel, click on 
BuildingPad. With the Line tool, trace the perimeter of the entire implementation of the Ground 
Floor (except the ramp and the access that will be added separately). The lines must form a closed 
perimeter without crossing each other.  

 

When clicking on Finish Edit Mode, an error window will appear. The error occurs due to overlapping 
pads, that is to say you cannot create the pad on the Ground Floor level on top of where there is 
already a pad on the Basement level. Click on Cancel to return to the edit mode.  

 

To correct the error, open the “Basement.dwg” view. Since you are still in edit mode, the perimeter 
outline made in the “Ground Floor.dwg” view is still visible.  
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Now, with the Line tool, you must change the contour making the lines pass only outside the 
Basement floor implantation. It is necessary to delete the lines that overlap the Basement level, so 
that it looks like the following image:  

 

After defining the thickness of 0.35 m and in the Height Offset from Level parameter, enter the value 

–0.10 m, click on OK until you return to the Design Area and then on Finish Edit Mode . 

In the 3D view, the result of creating the Ground Floor pad looks like the image below: 
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Now a pad will be added at the entrance to the residence. You can use the Rectangle tool to 
delimit the outline. Edit the Height Offset from Level parameter to –0.20 m from the Ground Floor.  

 

 

In the ramp access, a rectangular pad will also be inserted. You can use the Rectangle tool to  
delimit the outline. Edit the Height Offset from Level parameter to -0.50 m relative to the Ground 
Floor. 
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To create the ramp pad, open the “Basement.dwg” view. On the Massing & Site tab, Model Site 

panel, click BuildingPad. With the Line tool  , trace the perimeter of the entire ramp.  

 

On the Modify | Create Pad Boundary, select the Slope Arrow tool. 

 

Insert the arrow in the middle of the ramp, as in the image below. 

 

Select the arrow and in the Properties Palette, in the Specify parameter, the Height at Tail option will 
be kept. In Level at Tail, set Basement and the Height Offset at Tail value will be –0.10m. In Level at 
Head, the level will be the Ground Floor, with the Height Offset at Head parameter of –0.50 m.  
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If you intend to change the perimeter of any pad, you must select the object and click on the Edit 
Boundary button in the Modify tab. If you just want to change the Type or Instance parameters, 
select the object and access the Properties Palette (no need to edit the object). 

 Note: Differences in elevation between the pads and the terrain can be corrected by 
introducing new points on the topographical surface with the desired dimensions or 
changing the dimensions of existing points. It is recommended to make these adjustments 
only after inserting the walls so that the changes in points are easily visible 

In this project, the terrain overlaps some elements at the Ground Floor level, so it is recommended 
to add points in the areas highlighted in yellow in the image below.  
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At the top of the ramp, the points must have an elevation of 2.20 m, on the perimeter of the 
entrance floor an elevation of 2.50 m, and on the side and back, also 2.50 m. Next, there will be an 
explanation of how to add points and change elevations. 

To add new points, click on the terrain and in the Modify tab, click on Edit Surface. 

 

Then select the Place Point tool.  

 

In the options bar, select the Relative to Surface option and keep the Elevation field with the value of 
0.00 m.  
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Bring the mouse cursor to the surface of the land and click on the place where you want to insert the 
point. 

To change the elevation of the point, click on it and in the Properties Palette enter the desired value 
for the Elevation parameter.  

 

Click on Apply and visualize in the 3D view if the result obtained was what you intended or if you 
need to add more points or edit the elevation of the point again. 

5.9 – Create an Architectural Model 

5.9.1 Create walls 

From the imported plans, it’s possible to start inserting the construction elements. We will start with 
the insertion of walls, because elements such as doors and windows can only be inserted in a host 
element, in this case, walls. 

Before drawing the walls, a new wall type will be created from an existing model in Revit. To do this, 
access the Architecture tab and click on Walls. In the Properties Palette, select the wall of the type 
"Basic Wall: Generic - 200mm."  
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After selecting the type of wall, in the Properties Palette, click on the Edit Type button to open a 
Type Properties window, then click on Duplicate to create a new type of wall and the changes made 
do not affect the original type of wall. Define the new type with the following name: “.Ext 40cm”. 

 

In the Function parameter, keep the setting: Exterior. 
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In Structure, click on Edit to open the Edit Assembly window, which serves to change the wall layers. 
This type of wall has only one layer, so other layers with distinct functions, materials and thicknesses 
will be added. 

 

First you must change the existing layer. In Function, keep Structure [1] selected. In Materials, click 
on the icon  to open the Material Browser window, which will show all materials contained in the 
Revit library. To make the search easy, you can type the name of the material in the search bar at 
the top of the window. In this case, select the Brick Common material, click OK to close the Material 
Browser window. In Thickness, enter the value of 0.35 m for this layer. 
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To insert a new layer, click on Insert. It´s possible to move layers to the inner side or the outer side 
by clicking Up or Down. 

Insert four new layers, two with the Substrate function and with a thickness of 0.025 m and another 
two with the Finish function, and with a thickness of 0.0008m, which is the minimum thickness 
accepted by Revit. Another option is to place the paint layer with the Membrane Layer function, in 
which you can enter 0.00 m for the thickness. The materials of these layers will be added next. 

Due to the input of the value for the Finish layer, the Total thickness of the wall will be 0.4016 m. For 
more accurate measurements, the Structure layer thickness will be changed to 0.3484 m so that the 
total thickness is exactly 0,40 m.  
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Now the materials of these created layers will be inserted. By clicking on the icon  and searching 
for “plaster” or “paint" materials, these are not found in the Revit library, it is possible to create new 

materials. By clicking on the Creates and Duplicates Materials , a new material will be created 
with the name “Default New Material” which can be renamed in the Identity tab, under Name. 
Rename "Cement Plaster".  
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With the new material selected, it’s possible to search for pre-defined materials to link, by clicking 

on the Opens/Closes asset browser . When opening the Asset Browser window, to help the 
search, you can type the name of the material in the search bar. When typing Plaster, the material 
“Cement Plaster” appears.  

 

Right-click and select the Add to > Document Assets option to link this asset to the newly created 
asset.  

 

For the Finish layer, follow the same procedure: create a new material, rename the material to 

“White Paint”, click on the Opens/Closes asset browser , in the Asset Browser window search for 
”Paint”, and finally select the “White” (Appearance Library:Wall Paint:Matte).  
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When finishing the insertion of layers, the wall will have the definitions of the image below. Then 
just click on OK and the wall will be created.  

 
 

In this project there are also 0.20 m interior walls with the same materials. To create them, just 
select the wall type “.Ext 40cm” and click on Duplicate and name the new wall type “.Int 20cm”. 
Then, in the Function parameter, change to Interior. In Structure, click on Edit to open the Edit 
Assembly window, and the only change to be made is the thickness of the Brick layer, which will 



   
 BIM & Revit Architecture  
 

35 
 

change to 0.1484m and the Total thickness is automatically updated to 0.20 m. Repeat the same 
process to create the wall “.Ext 20cm”. 

After configuring the layer properties, it is possible to start inserting the exterior walls of the 
Basement floor. From the Project Browser, open the “Basement.dwg” view, which was created 
earlier, to insert this floor plan that was imported in .dwg format.  

 

In the Architecture tab, to enable the wall insertion tool, just select Wall, or, on the keyboard, type 
the command “WA” (without pressing the enter key), then choose the type of wall. In Properties 
select the wall “.Ext 40cm”. 

It is necessary to define the parameters of the Wall Instance (height and reference line of the wall 
drawing). 

In the Options Toolbar, in the Height parameter, change to Ground Floor (implicitly specify the 
height of the wall up to the Ground Floor level); in Location Line, select Finish Face: Exterior (wall 
alignment made by the exterior side of the wall); keep the Offset at 0.00 m. Check the Chain option 
to draw walls continuously.  

 

In the Properties Palette, under Base Constraint, select the Basement option, to define the reference 
level for the base of the walls. The negative offset to settle the walls below the Basement floor level 
is done in Base Offset, set the value to –0.10 m, because the walls are laid below the finishing floor 
that will be inserted later.  
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You have the option to place the walls in lines, rectangles or other shapes. In this case, keep the Line 
option.  

 

To represent the walls, zoom in as much as necessary so that you can select the outline of the walls. 
To invert the alignment of the interior or exterior face of the wall, simply press the spacebar before 
inserting it. 

It is not necessary to interrupt the walls in the openings of doors and windows, because when these 
other elements are inserted, the opening will open automatically.  

 

To view the inserted walls in gray, in the Visual Style icon, in the View Bar, you can select the visual 
of the inserted elements, by selecting Consistent Colors.  
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After adding all the exterior walls, in the properties window, change the wall type “.Int 20cm” and 
repeat the same process to insert the interior walls. Then change the type of wall to “.Ext 20cm” and 
insert the wall exterior (next to ramp).  

 

The properties of exterior wall (next to ramp) should be changed to Base Constraint: Basement; Base 
Offset: -0.10 m; Top Constraint: Unconnected; Unconnected Height: 3.50 m. To do so, select the wall 
and edit the parameters in the Properties window.  

 

To make the exterior wall (next to ramp) inclined, you must click on it to select it.  In the Modify tab, 
select the Edit Profile tool.  
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 Note 1: For a better view in Profile Edit mode, it is recommended to open a section view 
where the wall is visible. (see how to create a section view in item 5.9.8)  

 

Using the Line tool , draw an inclined line at the base of the wall that meets the ramp. Trim the 
lines using the Trim tool, so the contour looks like this: 

 

In the Mode panel, click on Finish Edit Mode to complete it. 

 

The walls drawn on the lower floor may be visible in the upper floor plan views. To change this 
parameter, access the properties window and in the Underlay parameter, Range: Base level, set it to 
None.  
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After inserting all the Basement level walls, repeat the entire process for the Ground Floor. To do 
this, open the view “GroundFloor.dwg”. For each floor you need to define the parameters of the 
Wall Instance, as you did for the Basement floor. 

On Ground Floor, the Height parameter will be Roof, and the Base Constraint will be Ground Floor. 
In Location Line, select Finish Face: Exterior, keep the Offset value at 0.00 m. 

Next for the Roof floor, open the Roof view because in this case none .dwg file was imported. The 
walls of this floor will be based on the external walls of the Ground Floor. In this case, the 
visualization of the walls drawn on the lower floor can be activated again. 

In the Height parameter, set the Unconnected option and enter the value of 0.80 m, which will be 
the height of the parapet, and the Base Constraint select Roof. In Location Line, select Finish Face: 
Exterior, keep the Offset value at 0.00 m. 

 

After inserting all the walls, with the Visual Style in Realistic mode and in 3D view, the model will 
look like the following image:  
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 Note 2: It is possible to insert walls without being based on an imported drawing in .dwg 
format. For this, the process is basically the same as the one mentioned so far.  The 
difference is that the walls will not be drawn on top of an imported plan. Just select the 
level where you want to insert the walls and draw them in free format, with dimensions 
adapted to the project in which you are working. 

 Note 3: At this stage, it is recommended to level the terrain, as explained in Note of item 
5.8. 

5.9.2 – Place Doors 

To insert the doors, go to the Architecture tab, Build panel and click on Door.  

 

In the Object Type Selector, select the M_Single-Flush door type: 0762x2032mm.  
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To create a door of the same family but with different dimensions, click on Edit Type, Duplicate and 
rename to “0.80m x 2.10m”. The Type Properties Palette will then open, where only the Height (2,10 
m) and Width (0,80 m) parameters will be changed.  

 

Repeat the same process for all the families and their respective dimensions that are required for 
the project. In this case, the doors used were: 

• M_Single-Flush: 0.80 m x 2.10 m (D1) 
• M_Single-Flush: 0.70 m x 2.10 m (D2) 
• M_Single-Flush: 1.50 m x 2.50 m (D3) 
• M_Door-Double-Sliding: 4.00 m x 2.10 m (D4) 
• M_Door-Double-Sliding: 3.00 m x 2.10m (D5) 
• M_Door-Double-Sliding: 2.00 m x 2.10 m (D6) 
• M_Door-Garage-Flush_Panel: 4.85 m x 2.20m (D7) 

In the Drawing Area, open the view where the .dwg plan was (“Basement.dwg” or “Ground 
Floor.dwg”) so that you can see where the doors are located. For a better view, on the View bar 
select the Wireframe option, so that the walls drawn in Revit do not hide the doors and windows.  
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Bring the mouse to the wall where you want to insert the door. Some temporary reference 
dimensions appear that help to place the object, which can be edited after the object placement. 
Click on the wall to insert. After introducing the door, press the Esc button. 

 

To be able to change the distances between the door and the walls, click on the door and then on 
the dimension value and type the new distance you want, ending up by clicking on Enter. 

To invert the door's orientation, you can click on  and  , or press the spacebar key. 

5.9.3 - Place Windows 

Inserting windows is basically the same as inserting doors. You must go to the Architecture tab, Build 
panel and click on Window.  

 

In the Object Type Selector, select the M_Fixed window type: 0406x0610mm. 
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To create a window of the same family but with different dimensions, click on Edit Type, Duplicate 
and rename to “0.50m x 1.00m / 1.90m”. The Type Properties window will then open, where the 
Height (0.50 m) and Width (1.00 m) parameters will be changed, as well as the Default Sill Height 
(1.90 m). 

Repeat the same process for all families and their respective dimensions that are required for the 
project. In this case, the windows used were: 

• M_Fixed: 1.00m x 0.50m / 1.90m (W1) 
• M_Window-Sliding-Double: 3.00m x 1.20m / 0.,90m (W2) 
• M_Window-Sliding-Double: 3.90m x 1.20m / 0.90m (W3) 
• M_Window-Sliding-Double: 2.50m x 1.20m / 1.00m (W5) 
• M_Window-Single-Hung: 1.60m x 0.60m / 1.50m (W4) 
• M_Window-Single-Hung: 1.10m x 0.60m / 1.90m (W6)  
 

If in any family it is not possible to edit the “Default Sill Height” parameter in the Type Properties 
window, you must edit the Sill Height parameter in the Properties Palette with the desired value for 
the sill. 
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5.9.4 - Create Floors 

To create a floor, it is necessary to draw an outline to create the boundary. There are several ways to 
create boundaries for floors.  In this case, the boundary outline will be drawn based on the existing 
walls. If a wall is moved to accommodate a design change, the floor will also automatically move 
with it. 

The floor boundary must be a closed loop. To create an opening in the floor, it is possible to sketch 
another closed loop where the opening should appear. 

In the Project Browser, select the Basement.dwg plan.  In the Architecture Tab, Build panel, select 
the Floor tool.  

 

On the Modify | Create Floor Boundary, in the Draw panel, select the Pick Walls tool, to draw the 
boundaries based on the existing walls.  

 

 In the Options Bar, check that the option Extend into wall (to core) is selected (this option allows the 
slab area to be defined up to the wall core line). In the Offset field, keep 0.00 m.  

 

Position the cursor over the walls and click on each one to place a boundary line, the alignment of 
the floor will be on the outside of the wall, as shown in the image.  
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To trim the lines that exceed the boundary, access the Modify | Create Floor Boundary, and in the 

Modify panel select the tool Trim/Extend to Corner  . Trim the corners of the boundary by 
selecting the lines on the sides that will be kept. 

After drawing the outline of the floor boundaries, in the Properties Palette, select the material 
“Generic 150mm” and click on Edit Type to open the Type Properties window. When opening the 
window, click on Duplicate and rename it to “Generic 10cm”. In Structure, click on Edit to open the 
Edit Assembly window and change the layer thickness to 0.10 m. Keep the Function parameter as 
Interior.  

 
 

After the boundary forms a closed loop, on the Mode panel, click on Finish Edit Mode . 
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After clicking Finish Edit Mode, the following messages may appear:  

 

This message allows you to connect the top of the walls with the lower face of the slabs. It is 
suggested that you click on Don’t Attach. 

 

This message intends that Revit subtracts the common part between the Slab and the Wall, it is 
suggested to answer Yes. 

As with all other building elements in Revit, it is possible to set the floor parameters using the 
Properties Palette You can change the floor family, function (indoor/outdoor) and create new types, 
with layers of varied materials and thicknesses as needed for each project. 

For this project, only generic floors will be used. 

To insert the project's floors, in the Basement, Ground Floor and Roof plans, you must perform the 
same procedure to draw the contour. 

In the stairs area, create a rectangle to make an opening in the floor.  

 
 

The interior floor of the Ground Floor should look similar to the following image. After the contour is 
bounded fully closed, in the Mode panel click Finish Edit Mode  to complete the drawing. 
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Then, to apply the exterior floors of the Ground Floor, in the Properties window, duplicate the 
created floor and create a new one, just changing the Function parameter to Exterior to be used on 
the balconies on the Ground Floor. 
 
  
As the floor boundary must be a closed circuit, to place all the exterior floors, they must be created 
separately, as shown in the following images. 
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Balcony floor, using the Line tool:

  
Access floor, using the Rectangle tool:
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Ramp access floor, using the Rectangle tool: 

  
 

5.9.5 - Create Stairs and Railings 

To create stairs, access the view which will be the base of the strairway. In this case, open the 
Basement.dwg floor plan. 

After opening the plan, in the Architecture tab, Circulation panel, select the Stairs icon.  

 

In the Properties Palette, under Constraints, set on Base Level: Basement, and on Top Level: Ground 
Floor. 
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In this case, other stairs properties will not be changed, but it is possible to change many other 
parameters by clicking on Edit Type, even the calculation rules (Calculation Rules).  

 

 In the Options bar, set the location line to Run:Center. 
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In the Basement plan, zoom in so that the stairs is visible and click on the center of the base step to 
start running the stairs. Move the cursor to the end of the stairs and click on the center of the last 
step. 

 

In the Mode panel, click on Finish Edit Mode to complete. 

The stairs will be created, and to better visualize the strairway in the 3D View, after selecting the 

stairs, just click on the Selection Box  in the View panel of the tab Modify | Stairs. 

A 3D view will open with a cutout of only the selected stairs, and it is possible to see that the railings 
were inserted automatically. To edit a railing, just click to select it. 

 

In the Properties Palette it is possible to edit the type of handrail and its dimensions. In this case, the 
railings on the side of the wall will be removed by selecting the element and press up the delete key. 

To return to the 3D view of the entire project, just select the Section Box clicking on one of its edges, 
and in the Properties Palette, deselect the Section Box option. 
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Repeat the same process for all the stairs in the project. 

It is possible to insert railings without being linked to a stairway, for example, on balconies. To do 
this, access the Architecture tab, Circulation panel and select the Railing tool. 

 

On the Modify | Create Railing Path, in the Draw panel, select the Line tool to draw the railing, 
double-clicking at the end of each line to make a continuous line. 

 

Draw the lines where the railing is to be inserted. 
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In the Properties Palette, change the railing type to “900mm Pipe”, so that it looks like the image 
below. 

 

5.9.6 - Create Ramp 

The easiest way to insert a ramp is by sketching a section with the Run tool, like creating stairs. 

First, open one of the plans in which the ramp of the imported file in .dwg format is visible 
(Basement.dwg or Ground Floor.dwg). 

Click on the Architecture tab, Circulation panel and select the Ramp tool.  

 

Open the Modify tab | Create Ramp Sketch, in the Draw panel select the Line tool. 
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After selecting the Line tool, move the cursor towards the drawing area and click on the base and 
top of the ramp to sketch the section. 

 

In the Properties Palette set: 

-  Base Level: Basement 
- Base Offset: 0.00 m (offset below Basement floor) 
- Top Level: Ground Floor 
- Top Offset: -0.40 m (offset below Ground Floor) 
- Width: 4.80 m 
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Click on Edit Type and change the Thickness to 0.10m and Ramp Max Slope parameter to 1.5 (15% 
slope). 

 

In the Mode panel, click on Finish Edit Mode to complete. 

Note: If when defining the length of the ramp with the Line command, it does not assume the true 
length, edit it by clicking on the line and dragging it to the end of the ramp. 
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If the ramp is inserted with railings, just select it and press the delete key to remove it.  

The appearance of the ramp should look similar to the image below: 

 
 

If it is necessary to edit the ramp, it must be selected and in the Modify | Ramps, click on the Edit 
Sketch tool.  

 

5.9.7 - Create Roof 

From the Project Browser, access the Roof floor plan.  In the Architecture tab, Build panel, Roof tool 
– by Footprint. 
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 In the Modify | Create Roof Footprint, Draw panel, select the Rectangle or Line tool to draw the 
outline of the roof boundary. 

 

Using the Rectangle tool, draw a rectangle by clicking on the interior face of the walls. Select the 
inferior line and move it 0.125 meters in relation to the wall, to leave space for the gutter, so that it 
looks like the figure below. 

 

Select the line that was moved, and in the Options Bar, check the Defines Slope option. Uncheck this 
option for the other lines, as the roof will only fall to one side.  

 

With the line that was moved selected, in the Properties window, in the Slope parameter, set it to 
10%. In the Mode panel, click the Finish Edit Mode icon to complete. 

The type of roof that will be used will be Basic Roof / Generic – 125mm.  
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Click on Edit Type to open the Type Properties window. In the Structure parameter, click on Edit to 
open the Edit Assembly window. In the Material column, click on the icon with three dots to open 
the Material Browser window. In the search bar, look for the material “Roofing, Tile” and select it. 

 

In the Mode panel, click on Finish Edit Mode to complete. 
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To insert the gutter, access the Architecture tab, Roof tool and select the Roof: Gutter option. 

 

After selecting the tool, just click on the roof line where the gutter should be inserted. It is not 
necessary to edit any parameters of the gutter, it will adjust to the available space that was left 
previously (0.125 m). 

 

Repeat the same process for the other areas of the coverage, so that the roofs are like the image 
below: 
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5.9.8 Create Section Views 

Creating sections views is very simple. In the Project Browser, select the plan of one of the floors. 

 In the View tab, Create panel, select the Section tool. 

 

Move the cursor to the plan and click on a point outside the boundary of the walls. After clicking on 
the first point, pass the line over the design and click on another point on the opposite side so that 
the section is created. 

 

To invert the section, just click on the Flip Section icon. 
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To open the section view, just double click on the section header symbol. You can also open the view 
from the Project Browser, where a view is automatically created for each section. 

 

When you open the section, the floor levels also appear. 

 

It is possible to create several sections.  For this project, four sections were created, as shown in the 
following image: 



   
 BIM & Revit Architecture  
 

62 
 

 

5.9.9. - Join Elements 

There is a tool that joins or separates object geometries. For example, in this project there are lines 
joining the walls of different floors, but these lines do not make sense as they are the same 
materials. 

 

To access this tool, open the Modify tab and select Join Geometry. 

 

If you want several objects to be joined, in the Options Bar, select the Multiple Join option. 
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After selecting the tool, click on the elements that you want to join. The result will be as in the image 
below: 

 

This tool should be used whenever necessary, to join walls, floors and other elements. It is also 
recommended to see in the Section views if there are elements to be joined. 

However, in some cases, this tool doesn’t work, so a small analysis of the design and manual 
adjustment is necessary. 

5.9.10 - Components: Furniture 

Revit allows you to insert more components such as furniture and garden elements. To insert them, 
access the Architecture tab, Build panel and click Component, Place a Component. 

 

In the Properties Palette, you can choose the type of element you want to insert. 
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By clicking on Load Family, in the Modify tab, it is possible to load more components from the Revit 
library according to each user's preference, as was done for the doors and windows previously. 

 

In the Furniture folder, there are several types of objects that can be inserted in a project. For 
example, a Bed family will be loaded. 

 

To be able to rotate objects in a certain orientation, just bring the object to be introduced close to 
another object (wall, line, ...) and click on the keyboard's Spacebar. 
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5.9.11- Annotations 

Revit provides several annotation tools to insert into projects. Next, the way to use some of these 
tools, such as: room name and area, dimensions, floor dimensions, texts, detail lines will be shown. 

It is important to note that annotations are placed in the view where they were created and are not 
visible in any other view. 

5.9.11.1 Room Tags 

Revit has a tool to enter the names of rooms and their respective areas. With the view of one of the 
plans open, access the Architecture tab, in the Room & Area panel, and select the Room tool. 

 

In the Properties Palette select the “Room Tag With Area” family. 

 

When you bring the mouse close to an environment enclosed by walls, Revit automatically 
recognizes the space and calculates the area. Click on the environment to enter the text. 



   
 BIM & Revit Architecture  
 

66 
 

 

To edit the environment name, just double click on its title and rename it. 

To delete room numbering, access the Properties Palette, click Edit Type, and in the Type Properties 
window, uncheck the option “Show Room Number”. 

 

When deleting the room numbering, a very large space is kept between the Name and Area text. 

 

To remove this space, it is necessary to edit this tag's family. To do this, double-click on the text in 
the area, and a new tab will open for editing. You must remove the text box with the number and 
volume and drag the text box from the area closer to the name of the environment, so that it looks 
like the one shown in the image below. 
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To apply this edition, click on the Load into Project icon. 

 

Select the option "Overwrite the existing version" 

 

In rooms that are not closed off by walls on all sides, for example in the Living Room, Dining Room 
and Kitchen, it is necessary to create an Environment Separator. To do this, access the Architecture 
tab, Room & Area panel, and select the Room Separator tool. 

 

This tool allows you to draw lines to delimit the area of the rooms. In the example in the image 
below, lines have been drawn to separate the Living Room, Dining Room and Kitchen. 
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After inserting the separators, you can use the Room tool normally as in a closed room. 

Based on the above instructions, name all the environments according to the plans of the files in 
.dwg format. 

5.9.11.2 Text 

There is also the possibility to add texts without adding an environment. To do this, access the 
Annotate tab, Text panel and select the Text tool.  

 

To add only one free text box, select the first option “No Leader” or select options with indicative 
arrows, which can be: one segment, two segments or curved. 

 

This tool is useful for naming some project specifications, such as materials: 

 

5.9.11.3 Dimensions 

To insert the dimensions in the project, you can access the Align Dimension tool, in the Quick Access 
Toolbar. 

 

In the Options Bar, select the options “Wall faces” and “Individual Reference”. 
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To insert the dimensions in the plans, click on the face of the wall where the dimension will start, 
then on the face of the wall where it will end, and finally drag the dimension to the wanted position 
and click to position it. 

 

It is possible to only move the dimension text. To do this, click on the circle below the text and drag 
it to the desired position. 

 

You can change the style of the representation (lines, symbols and font). In this case, the default 
configuration for the “Diagonal - 2.5mm Arial” type will be maintained. 

 

To make changes, if necessary, click Edit Type to open the Type Properties window. This window 
shows several parameters that can be changed, such as: tick mark, color, size and font of the text. In 
this case, only the parameter Color was changed to Red.  
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In the same way, you can insert dimensions in section views. 

 

5.9.11.4 Spot Elevation 

It is possible to define and represent the floor dimensions in different views, either in plan views or 
in section and elevation views. 
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To start, open the view in which you want to insert the floor dimensions. In this case, open the 
Basement plant. 

Access the Annotate tab, Dimension panel and click on Spot Elevation.  

 

In the Properties window, select the Spot Elevations: Target (Project) option. 

 

In the Options Bar, remove the Leader option.  

 

Click on the place where you want the object to be introduced. Proceed in the same way to insert all 
objects, in the Basement and Ground Floor plans. 

 

To insert altimetric dimensions in the sections (or any other view of the model), the procedure is the 
same. 

5.9.11.5 Tags 
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It is possible to insert tags that identify the introduced objects. These tags have a parametric link 
with the objects they  refer to. ,  That is to say, if the object is moved, the tag is also automatically 
moved in the same way that, if the object is removed, the tag will also be. 

To insert the tags, with one of the plans open (Basement or Ground Floor), access the Annotate tab, 
Tag panel and select the Tag All tool. 

 

A window will open to select the categories of elements in which the tags will be added. For this 
project, select only the “Door Tags” and “Window Tags” options. 

 

After clicking on OK, it can be seen that labels have been inserted in all elements of the view 
(perform the same process for Basement and Ground Floor views). 

Inserted tags are automatically numbered in the order in which the elements were added to the 
project. For reasons of organization, all doors or windows of the same type should be identified by 
an identical label. 

To edit this parameter, click on one of the labels and in the Modify tab, click on the Edit Family icon. 
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A window for editing the family will open. The value 101 is a representative value; it serves to 
confirm the size and color of the text. 

 

 
To change the text size, click on Edit Type to open the Type Properties window. In this window, click 
on Duplicate and rename to “2mm”. In the Text Size parameter, change the value to 2.00 mm and 
click on OK. 

 

What is also intended to change is that the information provided for the label is the parameter that 
identifies the type of port. To do this, select the text and click on Edit Label  in the  Modify panel. 
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When opening the Edit Label window, in the Category Parameters column, select Type Mark and 
click on Add parameter to label. 

 

After clicking on OK, in the Family Editor panel, click on the Load into Project icon. 

 

The window with the warning, Family Already Exists, will appear, select the option “Overwrite the 
existing version”. 

 

Automatically all door and window labels that are of the same type will have the same numbering. 
To rename it just click on their text. 

For example, a door label of 0.80m x 2.10m was renamed to “D1” and automatically all the doors of 
this dimension had their labels renamed with the same text. 
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Once the labels are configured, all doors must be renamed with the prefix “D” and the windows with 
the prefix “W”, followed by their respective numbering (see .dwg file to verify the numbering of 
doors and windows). Perform the same procedure for Basement and Ground Floor plans. 

After everything has been changed, the result will be as shown in the image below: 

 

5.9.11.6 Detail Lines 

Revit allows you to draw detail lines, which serve to represent some elements, such as the slope of 
the ramp. 

To use this tool, you need to access the Annotate tab, Detail panel and select the Detail Line tool. 

 

With the Line tool, draw the representation of the ramp as in the image below. Press the Esc key to 
exit edit mode. 
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5.10. - Create Schedules 

Tables also correspond to views of a project, not in the form of a drawing, but in the form of data, 
which characterize the objects that make up the model. They can later serve as a basis for measuring 
and budgeting a project. 

Tables also have a dynamic relationship with the model, that is to say, any changes made to the 
table are automatically reflected throughout the project (and vice versa). Since the tables are 
automatically updated, they can be created at any point in the project. 

As an example, in this project a table will be created to count the number of ports according to its 
Type. 

In the View tab, Create panel, click on Schedule/Quantities.  

 

In the window that appears, it is possible to define the category to be counted, in this case Doors, as 
well as to define the name to be assigned to the table (Name): Quantitative Schedule - Doors.  
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After clicking on OK, a window appears with all the fields that can be extracted from the Doors 
category. 

 

In the Fields tab it is possible to define which information to remove from objects. Just select in the 
Available Fields column and click Add--> so they can move to the Scheduled Fields column (in order). 
In this case, the following parameters were added: Type, Type Mark, Width, Height and Cost. 

It is possible to change the order of presentation of these parameters in the table. For that reason, in 
the Scheduled Fields column (in order), select the parameter and with the buttons Move Up and 
Move Down place in the desired position. If you need to remove any parameter that has already 
been defined, select it and click on the <--Remove button. 
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The Filter tab allows you to define filters for displaying the table's content, using the fields available 
for this purpose. No changes will be made to this tab. 

In the Sorting/Grouping tab it is possible to define how all the information will be sorted and 
grouped. In this case, sort by Port Type (Type Mark). 

 

When marking the Footer field, a footer line is fixed whenever you change the value of the field 
corresponding to the criterion (in this case, it will count all doors by Type). 

In the options box, choose the option Title, Count, and  Totals, defining that as the name of the 
group, the number of entries in the table and the totals of the fields that can be added are indicated 
in the footer: Partial Totals. 
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The Grand Totals field allows a row at the base of the table to be defined where information about 
the data of the table to which it refers is included. In the list of options, select the Totals option only 
so that, in this line, only the total sum of the fields that can be added appears: Global Totals. 

In order for all objects to be listed in the table without being grouped (in this case, do not group all 
the ports of the type in a single line), check the Itemize option at every instance. 

In the Formatting tab, you can define and change the default formatting for each field. In Alignment, 
select Center so that the text is aligned to the center of the cell. Change this same parameter in Type 
Mark, Width, Height and Cost. In Cost, define an additional parameter: Calculate totals (allows all 
values in this column to be summed).  

 

The Appearance tab allows you to change the appearance of the table, visible only when the table is 
inserted on the print sheet. This tab is divided into two parts: Graphics and Text. In this project, no 
changes will be made to this tab. 
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After clicking on OK, the following table will be obtained: 

 

If it is necessary to change the table´s configuration parameters, it can be changed through the 
parameters of the Properties window. 
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To enter a cost to the ports, just enter the value in the respective cell. Once entered, click on Enter. 
A change confirmation window will appear, which should select OK. When changing a parameter of 
the Type, this value will automatically be filled in the remaining ports of the Type. 

 

Another type of table that can be very useful is the Areas table. The creation mode is very similar. 
Access the View tab, Create panel, Schedules tool, Schedule/Quantities option. 

At the beginning of the creation of the table, choose the Rooms category. 
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After clicking on OK, in the Fields tab, define the following parameters for the table: Level, Name and 
Area. 

 

In Sorting/Grouping, sort the table by Floor (Level) and then by Name (Name). Also set the Totals 
only option in Footer (this option will show the partial totals per floor). Also define the Name 
parameter as a second ordering option. If you want to get grand totals, select Totals only under 
Grand Totals. 
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In Formatting, define that in the Area field it is possible to perform the calculation of totals 
(Calculate totals). Identify the Level field as a Hidden field (that is, the field is used to sort the table, 
but it will not be displayed in it). 

 

No changes will be made in the Appearance tab. Click on OK. 

The result of the table will be similar to the following image: 
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5.11. - Create Sheets and Print Setup 

To create sheets, access the Project Browser, right-click on Sheets and select the New Sheet option. 

 

In the New Sheet Window, select the “A1 metric” option. To insert other sheet sizes, click on “Load” 
to load other families. 
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In the Titleblocks folder, there are other types of sheets (A0, A1, A2, A3 and A4).  Just select the one 
you want and it will be loaded.  

 

After selecting the sheet size, click on OK and the sheet will be created. 
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By clicking on the texts, you can edit it according to the information you want to insert on the sheet. 

 

To insert views on the sheet, simply access the project browser, select the drawing and drag it to the 
sheet's blank space. If there is any change in the original view, it will be updated on the print sheet 
where it is introduced. 
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In this case, the Basement plan drawing took up a lot of space on the sheet. You can crop it by 
double-clicking on the drawing and using the Show Crop Region tool located in the preview bar (at 
the bottom of the Revit workspace). 

 

The blue lines show the clipping region. Therefore, these lines should be brought closer to the 
drawing to reduce the space occupied by it. Annotation elements will not be clipped.  

 

After adjusting the cropping region, in the preview bar, click on the Crop View tool and then on Hide 
Crop Region.  

 

Below the drawing, Revit automatically inserts the title and numbering. Numbering is in the order in 
which the drawings are dragged to the plan. Text can be edited and moved out of position. The line 
can be dragged to adjust the size.  

 

If necessary, they can be inserted in separate sheets.  For that, just create a new sheet according to 
the process explained above. For this project, 4 types of sheets were created: 
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Insert and adjust the following views: Basement, Ground floor, Schedule Areas, Roof, Site, Section 1, 
Section 2, Elevations (East, North, South, West).  

After inserting and adjusting all views, the result will be similar to the following image: 

 

To print the created sheets, click on the Print icon on the Quick Access Toolbar. 

 

The Print window will open. 
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In the Print Range area, you can define what will be printed: 

• Current Window – prints the current view or sheet; 
• Visible part of current window – prints the visible area of the view/active sheet (job print); 
• Selected views/sheets – simultaneous printing of multiple views (to be defined using the 

Select button). 

If you choose Selected views, a window will open to select the views or sheets you want to print. 

 

You can change the active configuration by clicking on Setup to open the Print Setup window. 
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• Paper: allows you to define the paper size to be used; 
• Orientation: allows you to define the orientation of the sheet; 
• Paper placement: allows you to define the alignment of the drawing in relation to the sheet; 
• Hidden Line Views: way of processing invisible lines (usually Vector Processing is faster and 

advisable for views that do not have shadows applied); 
• Zoom: allows you to define the scale factor for printing, it must always be at 100% since the 

scales of the views are defined in the project; 
• Appearance: Print quality (Raster quality parameter is only applied when there are views to 

which shadows have been applied) 
• Options: 

o View Links in blue: prints the symbols as shown in the graphics area; 
o Hide Ref/work planes: hides reference planes; 
o Hide unreferenced view tags: hides the tags that refer to views that are not placed 

on sheets; 
o Hide scope boxes: hides the lines of Scope Boxes; 
o Hide crop boundaries: hide crop boundaries; 
o Replace halftone with thin lines: changes lines defined as halftone (Halftone) to thin 

lines (Thin Lines). 

After defining all the wanted settings, just click OK and the sheets will be printed. 

5.12. – Rendering Revit has rendering tools to create images closer to the real result, offering 
more details and providing a better understanding of what was proposed in the project. 

https://www.youtube.com/watch?v=XXr_aerd7sk  

https://www.youtube.com/watch?v=XXr_aerd7sk
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https://www.youtube.com/watch?v=XXr_aerd7sk

